КОМПЛЕКСНИЙ АНАЛІЗ КОМУНІКАЦІЙНИХ ПРОТОКОЛІВ TCP/IP, UDP ТА HTTP У СУЧАСНИХ МЕРЕЖАХ

Автор(и)

  • Вадим СВАРИЧ Автор

DOI:

https://doi.org/10.17721/3041-2323.2024.449-455

Ключові слова:

комунікаційні протоколи, TCP/IP, UDP, HTTP, продуктивність мережі, аналіз протоколів, сучасні мережі, Інтернет речей (IoT), хмарові обчислення

Анотація

Представлено комплексний аналіз комунікаційних протоколів TCP/IP, UDP та HTTP у контексті сучасних мережевих технологій. У дослідженні розглянуто їхні основні принципи, переваги, недоліки й останні досягнення. Оцінено характеристики продуктивності, такі як затримка, пропускна здатність, стійкість до втрати пакетів, накладні витрати протоколу та масштабованість, із використанням практичних тестів та аналітичних методів. Отримані результати дають змогу оптимізувати вибір протоколу та його використання у різних сучасних мережевих застосуваннях, зокрема і в Інтернеті речей (IoT), потокових сервісах і хмарових обчисленнях.

Посилання

Cardwell, N., Cheng, Y., Gunn, C. S. et al. (2017). BBR: Congestion-based congestion control. Communications of the ACM, 60(2), 58–66.

Comer, D. E. (2018). Computer networks and internets (6th ed.). Pearson Education.

Fielding, R. T., & Reschke, J. (2014). Hypertext Transfer Protocol (HTTP/1.1): Message syntax and routing (RFC 7230). IETF.

Forouzan, B. A. (2017). Data communications and networking (5th ed.). McGraw-Hill Education.

Iyengar, J., & Thomson, M. (2021). QUIC: A UDP-based multiplexed and secure transport (RFC 9000). IETF.

Kurose, J. F., & Ross, K. W. (2017). Computer networking: A top-down approach (7th ed.). Pearson.

Thomson, M., & Bishop, M. (2022). Hypertext Transfer Protocol Version 3 (HTTP/3) (RFC 9114). IETF.

Title

Завантаження

Опубліковано

01.10.2024